summaryrefslogtreecommitdiffstats
path: root/package/nettle
diff options
context:
space:
mode:
Diffstat (limited to 'package/nettle')
-rw-r--r--package/nettle/Config.in9
-rw-r--r--package/nettle/nettle.mk12
2 files changed, 21 insertions, 0 deletions
diff --git a/package/nettle/Config.in b/package/nettle/Config.in
new file mode 100644
index 000000000..55776216e
--- /dev/null
+++ b/package/nettle/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_NETTLE
+ bool "nettle"
+ select BR2_PACKAGE_GMP
+ help
+ Nettle is a cryptographic library that is designed to fit easily
+ in more or less any context: In crypto toolkits for object-oriented
+ languages, in applications like LSH or GNUPG, or even in kernel space
+
+ http://www.lysator.liu.se/~nisse/nettle/
diff --git a/package/nettle/nettle.mk b/package/nettle/nettle.mk
new file mode 100644
index 000000000..ef7640a23
--- /dev/null
+++ b/package/nettle/nettle.mk
@@ -0,0 +1,12 @@
+NETTLE_VERSION = 2.5
+NETTLE_SITE = http://www.lysator.liu.se/~nisse/archive
+NETTLE_DEPENDENCIES = gmp
+NETTLE_INSTALL_STAGING = YES
+
+define NETTLE_DITCH_DEBUGGING_CFLAGS
+ $(SED) '/CFLAGS/ s/ -ggdb3//' $(@D)/configure
+endef
+
+NETTLE_POST_EXTRACT_HOOKS += NETTLE_DITCH_DEBUGGING_CFLAGS
+
+$(eval $(autotools-package))