summaryrefslogtreecommitdiffstats
path: root/package/nettle
diff options
context:
space:
mode:
Diffstat (limited to 'package/nettle')
-rw-r--r--package/nettle/nettle-Added-lm-when-linking-nettle-benchmark.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/nettle/nettle-Added-lm-when-linking-nettle-benchmark.patch b/package/nettle/nettle-Added-lm-when-linking-nettle-benchmark.patch
new file mode 100644
index 000000000..ca4d63976
--- /dev/null
+++ b/package/nettle/nettle-Added-lm-when-linking-nettle-benchmark.patch
@@ -0,0 +1,17 @@
+Added -lm when linking nettle-benchmark.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff --git a/examples/Makefile.in b/examples/Makefile.in
+index 909fdda..3becd08 100644
+--- a/examples/Makefile.in
++++ b/examples/Makefile.in
+@@ -11,7 +11,7 @@ PRE_CPPFLAGS = -I.. -I$(top_srcdir)
+ PRE_LDFLAGS = -L..
+
+ OPENSSL_LIBFLAGS = @OPENSSL_LIBFLAGS@
+-BENCH_LIBS = @BENCH_LIBS@
++BENCH_LIBS = @BENCH_LIBS@ -lm
+
+ RSA_TARGETS = rsa-keygen$(EXEEXT) rsa-sign$(EXEEXT) \
+ rsa-verify$(EXEEXT) rsa-encrypt$(EXEEXT) rsa-decrypt$(EXEEXT)