summaryrefslogtreecommitdiffstats
path: root/package/neon
diff options
context:
space:
mode:
Diffstat (limited to 'package/neon')
-rw-r--r--package/neon/neon.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/neon/neon.mk b/package/neon/neon.mk
index c570fc1da..0c237dcaf 100644
--- a/package/neon/neon.mk
+++ b/package/neon/neon.mk
@@ -45,4 +45,12 @@ else
NEON_CONF_OPT+=--without-ssl
endif
+define NEON_REMOVE_CONFIG_SCRIPTS
+ $(RM) -f $(TARGET_DIR)/usr/bin/neon-config
+endef
+
+ifneq ($(BR2_HAVE_DEVFILES),y)
+NEON_POST_INSTALL_TARGET_HOOKS += NEON_REMOVE_CONFIG_SCRIPTS
+endif
+
$(eval $(call AUTOTARGETS,package,neon))