summaryrefslogtreecommitdiffstats
path: root/package/neon
diff options
context:
space:
mode:
Diffstat (limited to 'package/neon')
-rw-r--r--package/neon/Config.in6
-rw-r--r--package/neon/neon.mk6
2 files changed, 12 insertions, 0 deletions
diff --git a/package/neon/Config.in b/package/neon/Config.in
index ce72a2fb6..318e4c6a3 100644
--- a/package/neon/Config.in
+++ b/package/neon/Config.in
@@ -12,6 +12,12 @@ config BR2_PACKAGE_NEON_ZLIB
help
build with ZLIB support
+config BR2_PACKAGE_NEON_SSL
+ bool "SSL support"
+ select BR2_PACKAGE_OPENSSL
+ help
+ build with SSL support
+
choice
prompt "XML Support"
default BR2_PACKAGE_NEON_NOXML
diff --git a/package/neon/neon.mk b/package/neon/neon.mk
index 1f26a0c96..ed5f99968 100644
--- a/package/neon/neon.mk
+++ b/package/neon/neon.mk
@@ -22,6 +22,12 @@ NEON_DEPENDENCIES+=zlib
else
NEON_CONF_OPT+=--without-zlib
endif
+ifeq ($(BR2_PACKAGE_NEON_SSL),y)
+NEON_CONF_OPT+=--with-ssl
+NEON_DEPENDENCIES+=openssl
+else
+NEON_CONF_OPT+=--without-ssl
+endif
ifeq ($(BR2_PACKAGE_NEON_EXPAT),y)
NEON_CONF_OPT+=--with-expat=$(STAGING_DIR)/usr/lib/libexpat.la
NEON_CONF_OPT+=--with-libxml2=no