summaryrefslogtreecommitdiffstats
path: root/package/multimedia/gst-plugins-base
diff options
context:
space:
mode:
Diffstat (limited to 'package/multimedia/gst-plugins-base')
-rw-r--r--package/multimedia/gst-plugins-base/Config.in4
-rw-r--r--package/multimedia/gst-plugins-base/gst-plugins-base.mk9
2 files changed, 12 insertions, 1 deletions
diff --git a/package/multimedia/gst-plugins-base/Config.in b/package/multimedia/gst-plugins-base/Config.in
index 8883a433f..f08be7eb7 100644
--- a/package/multimedia/gst-plugins-base/Config.in
+++ b/package/multimedia/gst-plugins-base/Config.in
@@ -72,6 +72,10 @@ config BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_OGG
bool "ogg (*.ogg audio/video)"
select BR2_PACKAGE_LIBOGG
+config BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_PANGO
+ bool "pango font renderer"
+ select BR2_PACKAGE_PANGO
+
config BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_THEORA
bool "theora (*.ogg video)"
select BR2_PACKAGE_LIBTHEORA
diff --git a/package/multimedia/gst-plugins-base/gst-plugins-base.mk b/package/multimedia/gst-plugins-base/gst-plugins-base.mk
index 63f23cd5c..bd422be0f 100644
--- a/package/multimedia/gst-plugins-base/gst-plugins-base.mk
+++ b/package/multimedia/gst-plugins-base/gst-plugins-base.mk
@@ -3,7 +3,7 @@
# gst-plugins-base
#
#############################################################
-GST_PLUGINS_BASE_VERSION = 0.10.23
+GST_PLUGINS_BASE_VERSION = 0.10.25
GST_PLUGINS_BASE_SOURCE = gst-plugins-base-$(GST_PLUGINS_BASE_VERSION).tar.bz2
GST_PLUGINS_BASE_SITE = http://gstreamer.freedesktop.org/src/gst-plugins-base
GST_PLUGINS_BASE_INSTALL_STAGING = YES
@@ -130,6 +130,13 @@ else
GST_PLUGINS_BASE_CONF_OPT += --disable-ogg
endif
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_PANGO),y)
+GST_PLUGINS_BASE_CONF_OPT += --enable-pango
+GST_PLUGINS_BASE_DEPENDENCIES += pango
+else
+GST_PLUGINS_BASE_CONF_OPT += --disable-pango
+endif
+
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_THEORA),y)
GST_PLUGINS_BASE_CONF_OPT += --enable-theora
GST_PLUGINS_BASE_DEPENDENCIES += libtheora