summaryrefslogtreecommitdiffstats
path: root/package/make
diff options
context:
space:
mode:
Diffstat (limited to 'package/make')
-rw-r--r--package/make/Config.in2
-rw-r--r--package/make/make.mk2
2 files changed, 3 insertions, 1 deletions
diff --git a/package/make/Config.in b/package/make/Config.in
index 7dc19c52e..52640058e 100644
--- a/package/make/Config.in
+++ b/package/make/Config.in
@@ -1,5 +1,7 @@
config BR2_PACKAGE_MAKE
bool "make"
+ select BR2_PACKAGE_GETTEXT if BR2_ENABLE_LOCALE
+ select BR2_PACKAGE_LIBINTL if BR2_ENABLE_LOCALE
help
A tool which controls the generation of executables and other
non-source files of a program from the program's source files.
diff --git a/package/make/make.mk b/package/make/make.mk
index 4f11f504d..4cc5e1597 100644
--- a/package/make/make.mk
+++ b/package/make/make.mk
@@ -71,5 +71,5 @@ make-dirclean:
#
#############################################################
ifeq ($(strip $(BR2_PACKAGE_MAKE)),y)
-TARGETS+=make
+TARGETS+=$(if $(BR2_PACKAGE_GETTEXT),gettext) make
endif