summaryrefslogtreecommitdiffstats
path: root/package/luafilesystem
diff options
context:
space:
mode:
Diffstat (limited to 'package/luafilesystem')
-rw-r--r--package/luafilesystem/Config.in6
-rw-r--r--package/luafilesystem/luafilesystem-without_large_file.patch20
-rw-r--r--package/luafilesystem/luafilesystem.mk6
3 files changed, 26 insertions, 6 deletions
diff --git a/package/luafilesystem/Config.in b/package/luafilesystem/Config.in
index 6cb6c2475..edcb414a9 100644
--- a/package/luafilesystem/Config.in
+++ b/package/luafilesystem/Config.in
@@ -1,12 +1,8 @@
config BR2_PACKAGE_LUAFILESYSTEM
bool "luafilesystem"
- depends on BR2_LARGEFILE
select BR2_PACKAGE_LUA_SHARED_LIBRARY
help
LuaFileSystem offers a portable way to access
the underlying directory structure and file attributes.
- http://luaforge.net/projects/luafilesystem/
-
-comment "luafilesystem requires a toolchain with LARGEFILE support"
- depends on !BR2_LARGEFILE
+ http://keplerproject.github.com/luafilesystem/
diff --git a/package/luafilesystem/luafilesystem-without_large_file.patch b/package/luafilesystem/luafilesystem-without_large_file.patch
new file mode 100644
index 000000000..b1f41c09d
--- /dev/null
+++ b/package/luafilesystem/luafilesystem-without_large_file.patch
@@ -0,0 +1,20 @@
+diff --git a/src/lfs.c b/src/lfs.c
+index 85f01e3..ed49f50 100644
+--- a/src/lfs.c
++++ b/src/lfs.c
+@@ -22,13 +22,13 @@
+
+ #ifndef _WIN32
+ #ifndef _AIX
+-#define _FILE_OFFSET_BITS 64 /* Linux, Solaris and HP-UX */
++//#define _FILE_OFFSET_BITS 64 /* Linux, Solaris and HP-UX */
+ #else
+ #define _LARGE_FILES 1 /* AIX */
+ #endif
+ #endif
+
+-#define _LARGEFILE64_SOURCE
++//#define _LARGEFILE64_SOURCE
+
+ #include <errno.h>
+ #include <stdio.h>
diff --git a/package/luafilesystem/luafilesystem.mk b/package/luafilesystem/luafilesystem.mk
index a27080cd6..e68873414 100644
--- a/package/luafilesystem/luafilesystem.mk
+++ b/package/luafilesystem/luafilesystem.mk
@@ -8,8 +8,12 @@ LUAFILESYSTEM_VERSION = 1.5.0
LUAFILESYSTEM_SITE = http://github.com/downloads/keplerproject/luafilesystem
LUAFILESYSTEM_DEPENDENCIES = lua
+ifeq ($(BR2_LARGEFILE),y)
+LFS_CFLAGS = -D_FILE_OFFSET_BITS=64 _LARGEFILE64_SOURCE
+endif
+
define LUAFILESYSTEM_BUILD_CMDS
- $(MAKE) -C $(@D) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS) -fPIC"
+ $(MAKE) -C $(@D) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS) $(LFS_CFLAGS) -fPIC"
endef
define LUAFILESYSTEM_INSTALL_TARGET_CMDS