summaryrefslogtreecommitdiffstats
path: root/package/luabitop
diff options
context:
space:
mode:
Diffstat (limited to 'package/luabitop')
-rw-r--r--package/luabitop/Config.in7
-rw-r--r--package/luabitop/luabitop.mk27
2 files changed, 34 insertions, 0 deletions
diff --git a/package/luabitop/Config.in b/package/luabitop/Config.in
new file mode 100644
index 000000000..83a85b16c
--- /dev/null
+++ b/package/luabitop/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_LUABITOP
+ bool "luabitop"
+ help
+ Lua BitOp is a C extension module for Lua 5.1/5.2 which adds bitwise
+ operations on numbers.
+
+ http://bitop.luajit.org
diff --git a/package/luabitop/luabitop.mk b/package/luabitop/luabitop.mk
new file mode 100644
index 000000000..c61e826c0
--- /dev/null
+++ b/package/luabitop/luabitop.mk
@@ -0,0 +1,27 @@
+################################################################################
+#
+# luabitop
+#
+################################################################################
+
+LUABITOP_VERSION = 1.0.2
+LUABITOP_SOURCE = LuaBitOp-$(LUABITOP_VERSION).tar.gz
+LUABITOP_SITE = http://bitop.luajit.org/download
+LUABITOP_LICENSE = MIT
+LUABITOP_LICENSE_FILES = README
+LUABITOP_DEPENDENCIES = lua
+
+define LUABITOP_BUILD_CMDS
+ $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS)
+endef
+
+define LUABITOP_INSTALL_TARGET_CMDS
+ mkdir -p $(TARGET_DIR)/usr/lib/lua
+ $(INSTALL) -p $(@D)/bit.so $(TARGET_DIR)/usr/lib/lua
+endef
+
+define LUABITOP_CLEAN_CMDS
+ $(MAKE) -C $(@D) clean
+endef
+
+$(eval $(generic-package))