summaryrefslogtreecommitdiffstats
path: root/package/lua-ev
diff options
context:
space:
mode:
Diffstat (limited to 'package/lua-ev')
-rw-r--r--package/lua-ev/Config.in7
-rw-r--r--package/lua-ev/lua-ev.mk14
2 files changed, 21 insertions, 0 deletions
diff --git a/package/lua-ev/Config.in b/package/lua-ev/Config.in
new file mode 100644
index 000000000..1e89c270a
--- /dev/null
+++ b/package/lua-ev/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_LUA_EV
+ bool "lua-ev"
+ select BR2_PACKAGE_LIBEV
+ help
+ Get access to the libev library from Lua.
+
+ https://github.com/brimworks/lua-ev
diff --git a/package/lua-ev/lua-ev.mk b/package/lua-ev/lua-ev.mk
new file mode 100644
index 000000000..2b03936c2
--- /dev/null
+++ b/package/lua-ev/lua-ev.mk
@@ -0,0 +1,14 @@
+################################################################################
+#
+# lua-ev
+#
+################################################################################
+
+LUA_EV_VERSION = 458165b
+LUA_EV_SITE = http://github.com/brimworks/lua-ev/tarball/$(LUA_EV_VERSION)
+LUA_EV_DEPENDENCIES = lua libev
+LUA_EV_LICENSE = MIT
+LUA_EV_LICENSE_FILES = README
+LUA_EV_CONF_OPT = -DINSTALL_CMOD="/usr/lib/lua"
+
+$(eval $(cmake-package))