summaryrefslogtreecommitdiffstats
path: root/package/lighttpd/lighttpd.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/lighttpd/lighttpd.mk')
-rw-r--r--package/lighttpd/lighttpd.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/package/lighttpd/lighttpd.mk b/package/lighttpd/lighttpd.mk
index 67cd27241..590180153 100644
--- a/package/lighttpd/lighttpd.mk
+++ b/package/lighttpd/lighttpd.mk
@@ -6,7 +6,7 @@
LIGHTTPD_VERSION = 1.4.28
LIGHTTPD_SITE = http://download.lighttpd.net/lighttpd/releases-1.4.x
-
+LIGHTTPD_DEPENDENCIES = host-pkg-config
LIGHTTPD_CONF_OPT = \
--libdir=/usr/lib/lighttpd \
--libexecdir=/usr/lib \
@@ -43,6 +43,13 @@ else
LIGHTTPD_CONF_OPT += --without-pcre
endif
+ifeq ($(BR2_PACKAGE_LIGHTTPD_WEBDAV),y)
+LIGHTTPD_DEPENDENCIES += libxml2 sqlite
+LIGHTTPD_CONF_OPT += --with-webdav-props --with-webdav-locks
+else
+LIGHTTPD_CONF_OPT += ---without-webdav-props --without-webdav-locks
+endif
+
define LIGHTTPD_UNINSTALL_TARGET_CMDS
rm -f $(TARGET_DIR)/usr/sbin/lighttpd
rm -f $(TARGET_DIR)/usr/sbin/lighttpd-angel