summaryrefslogtreecommitdiffstats
path: root/package/libxml2
diff options
context:
space:
mode:
Diffstat (limited to 'package/libxml2')
-rw-r--r--package/libxml2/Config.in3
-rw-r--r--package/libxml2/libxml2.mk10
2 files changed, 12 insertions, 1 deletions
diff --git a/package/libxml2/Config.in b/package/libxml2/Config.in
index ebd63fe54..ea62663dd 100644
--- a/package/libxml2/Config.in
+++ b/package/libxml2/Config.in
@@ -4,3 +4,6 @@ config BR2_PACKAGE_LIBXML2
XML C Parser
http://xmlsoft.org/
+
+config BR2_PACKAGE_HOST_LIBXML2_PYTHON
+ bool \ No newline at end of file
diff --git a/package/libxml2/libxml2.mk b/package/libxml2/libxml2.mk
index 71f2bd15b..fde3735b8 100644
--- a/package/libxml2/libxml2.mk
+++ b/package/libxml2/libxml2.mk
@@ -26,7 +26,15 @@ LIBXML2_POST_INSTALL_STAGING_HOOKS += LIBXML2_STAGING_LIBXML2_CONFIG_FIXUP
HOST_LIBXML2_DEPENDENCIES = host-pkgconf
-HOST_LIBXML2_CONF_OPT = --without-debug --without-python
+HOST_LIBXML2_CONF_OPT = --without-debug
+
+ifeq ($(BR2_PACKAGE_HOST_LIBXML2_PYTHON),y)
+HOST_LIBXML2_DEPENDENCIES += host-python
+HOST_LIBXML2_CONF_OPT += --with-python=$(HOST_DIR)/usr
+else
+HOST_LIBXML2_CONF_OPT += --without-python
+endif
+
define LIBXML2_REMOVE_CONFIG_SCRIPTS
$(RM) -f $(TARGET_DIR)/usr/bin/xml2-config