summaryrefslogtreecommitdiffstats
path: root/package/libvorbis
diff options
context:
space:
mode:
Diffstat (limited to 'package/libvorbis')
-rw-r--r--package/libvorbis/Config.in14
-rw-r--r--package/libvorbis/libvorbis.mk16
2 files changed, 30 insertions, 0 deletions
diff --git a/package/libvorbis/Config.in b/package/libvorbis/Config.in
new file mode 100644
index 000000000..e322dd256
--- /dev/null
+++ b/package/libvorbis/Config.in
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_LIBVORBIS
+ bool "libvorbis"
+ select BR2_PACKAGE_LIBOGG
+ help
+ Library for the Vorbis open source audio decoder
+ Ogg Vorbis is a fully open, non-proprietary, patent-and-royalty-free,
+ general-purpose compressed audio format for mid to high quality
+ (8kHz-48.0kHz, 16+ bit, polyphonic) audio and music at fixed and
+ variable bitrates from 16 to 128 kbps/channel.
+
+ This places Vorbis in the same competitive class as audio
+ representations such as MPEG-4 (AAC), and similar to, but higher
+ performance than MPEG-1/2 audio layer 3, MPEG-4 audio (TwinVQ),
+ WMA and PAC.
diff --git a/package/libvorbis/libvorbis.mk b/package/libvorbis/libvorbis.mk
new file mode 100644
index 000000000..68444144a
--- /dev/null
+++ b/package/libvorbis/libvorbis.mk
@@ -0,0 +1,16 @@
+#############################################################
+#
+# libvorbis
+#
+#############################################################
+
+LIBVORBIS_VERSION = 1.3.3
+LIBVORBIS_SOURCE = libvorbis-$(LIBVORBIS_VERSION).tar.gz
+LIBVORBIS_SITE = http://downloads.xiph.org/releases/vorbis/$(LIBVORBIS-SOURCE)
+LIBVORBIS_INSTALL_STAGING = YES
+
+LIBVORBIS_CONF_OPT = --disable-oggtest
+
+LIBVORBIS_DEPENDENCIES = host-pkg-config libogg
+
+$(eval $(call AUTOTARGETS))