summaryrefslogtreecommitdiffstats
path: root/package/libiscsi
diff options
context:
space:
mode:
Diffstat (limited to 'package/libiscsi')
-rw-r--r--package/libiscsi/Config.in12
-rw-r--r--package/libiscsi/libiscsi.mk15
2 files changed, 27 insertions, 0 deletions
diff --git a/package/libiscsi/Config.in b/package/libiscsi/Config.in
new file mode 100644
index 000000000..f3fc29ee4
--- /dev/null
+++ b/package/libiscsi/Config.in
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_LIBISCSI
+ bool "libiscsi"
+ select BR2_PACKAGE_POPT
+ help
+ Libiscsi is a client-side library to implement the iSCSI protocol
+ that can be used to access resource of an iSCSI Target.
+
+ The library is fully async with regards to iscsi commands and scsi
+ tasks, but a sync layer is also provided for ease of use for simpler
+ applications.
+
+ https://github.com/sahlberg/libiscsi (no proper homepage)
diff --git a/package/libiscsi/libiscsi.mk b/package/libiscsi/libiscsi.mk
new file mode 100644
index 000000000..bfebd7e2d
--- /dev/null
+++ b/package/libiscsi/libiscsi.mk
@@ -0,0 +1,15 @@
+#############################################################
+#
+# libiscsi
+#
+#############################################################
+
+LIBISCSI_VERSION = 1.6.0
+LIBISCSI_SOURCE = libiscsi-$(LIBISCSI_VERSION).tar.gz
+LIBISCSI_SITE = https://github.com/downloads/sahlberg/libiscsi
+LIBISCSI_LICENSE = GPLv2+ LGPLv2.1+
+LIBISCSI_LICENSE_FILES = COPYING LICENCE-GPL-2.txt LICENCE-LGPL-2.1.txt
+LIBISCSI_INSTALL_STAGING = YES
+LIBISCSI_DEPENDENCIES = popt
+
+$(eval $(autotools-package))