summaryrefslogtreecommitdiffstats
path: root/package/libffi/libffi.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/libffi/libffi.mk')
-rw-r--r--package/libffi/libffi.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/libffi/libffi.mk b/package/libffi/libffi.mk
index 75705835e..64b3eb412 100644
--- a/package/libffi/libffi.mk
+++ b/package/libffi/libffi.mk
@@ -8,9 +8,14 @@ LIBFFI_VERSION = 3.0.11
LIBFFI_SITE = ftp://sources.redhat.com/pub/libffi/
LIBFFI_LICENSE = MIT
LIBFFI_LICENSE_FILES = LICENSE
-
LIBFFI_INSTALL_STAGING = YES
+# Newer CS MIPS toolchains use a different (compact) eh_frame format
+# libffi don't like them, just switch to the older format
+ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201209)$(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201203),y)
+LIBFFI_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -mno-compact-eh"
+endif
+
# Move the headers to the usual location, and adjust the .pc file
# accordingly
define LIBFFI_MOVE_STAGING_HEADERS