summaryrefslogtreecommitdiffstats
path: root/package/libcurl
diff options
context:
space:
mode:
Diffstat (limited to 'package/libcurl')
-rw-r--r--package/libcurl/libcurl.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/libcurl/libcurl.mk b/package/libcurl/libcurl.mk
index 6a91bb262..fb04da05d 100644
--- a/package/libcurl/libcurl.mk
+++ b/package/libcurl/libcurl.mk
@@ -13,6 +13,11 @@ LIBCURL_CONF_OPT = --disable-verbose --disable-manual --enable-hidden-symbols \
ifeq ($(BR2_PACKAGE_OPENSSL),y)
LIBCURL_DEPENDENCIES += openssl
LIBCURL_CONF_ENV += ac_cv_lib_crypto_CRYPTO_lock=yes
+# configure adds the cross openssl dir to LD_LIBRARY_PATH which screws up
+# native stuff during the rest of configure when target == host.
+# Fix it by setting LD_LIBRARY_PATH to something sensible so those libs
+# are found first.
+LIBCURL_CONF_ENV += LD_LIBRARY_PATH=$$LD_LIBRARY_PATH:/lib:/usr/lib
LIBCURL_CONF_OPT += --with-ssl=$(STAGING_DIR)/usr --with-random=/dev/urandom
endif