summaryrefslogtreecommitdiffstats
path: root/package/jquery
diff options
context:
space:
mode:
Diffstat (limited to 'package/jquery')
-rw-r--r--package/jquery/Config.in8
-rw-r--r--package/jquery/jquery.mk17
2 files changed, 25 insertions, 0 deletions
diff --git a/package/jquery/Config.in b/package/jquery/Config.in
new file mode 100644
index 000000000..92f560427
--- /dev/null
+++ b/package/jquery/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_JQUERY
+ bool "jQuery"
+ help
+ jQuery is a fast and concise JavaScript Library that
+ simplifies HTML document traversing, event handling,
+ animating, and Ajax interactions for rapid web development.
+
+ http://jquery.com
diff --git a/package/jquery/jquery.mk b/package/jquery/jquery.mk
new file mode 100644
index 000000000..aba6301ca
--- /dev/null
+++ b/package/jquery/jquery.mk
@@ -0,0 +1,17 @@
+JQUERY_VERSION = 1.7.1
+JQUERY_SITE = http://code.jquery.com
+JQUERY_SOURCE = jquery-$(JQUERY_VERSION).min.js
+
+define JQUERY_EXTRACT_CMDS
+ cp $(DL_DIR)/$(JQUERY_SOURCE) $(@D)
+endef
+
+define JQUERY_INSTALL_TARGET_CMDS
+ $(INSTALL) -D $(@D)/$(JQUERY_SOURCE) $(TARGET_DIR)/var/www/jquery.js
+endef
+
+define JQUERY_UNINSTALL_TARGET_CMDS
+ rm -f $(TARGET_DIR)/var/www/jquery.js
+endef
+
+$(eval $(call GENTARGETS))