summaryrefslogtreecommitdiffstats
path: root/package/ipsec-tools
diff options
context:
space:
mode:
Diffstat (limited to 'package/ipsec-tools')
-rw-r--r--package/ipsec-tools/Config.in2
-rw-r--r--package/ipsec-tools/ipsec-tools.mk8
2 files changed, 4 insertions, 6 deletions
diff --git a/package/ipsec-tools/Config.in b/package/ipsec-tools/Config.in
index e7a948905..f868c6bb0 100644
--- a/package/ipsec-tools/Config.in
+++ b/package/ipsec-tools/Config.in
@@ -44,7 +44,7 @@ config BR2_PACKAGE_IPSEC_TOOLS_STATS
config BR2_PACKAGE_IPSEC_TOOLS_IPV6
default y
- depends on BR2_PACKAGE_IPSEC_TOOLS
+ depends on BR2_PACKAGE_IPSEC_TOOLS && BR2_INET_IPV6
bool "Enable IPv6 support"
help
This option has no effect if uClibc has been compiled without
diff --git a/package/ipsec-tools/ipsec-tools.mk b/package/ipsec-tools/ipsec-tools.mk
index d6b9c7bbe..52e53f25a 100644
--- a/package/ipsec-tools/ipsec-tools.mk
+++ b/package/ipsec-tools/ipsec-tools.mk
@@ -42,18 +42,16 @@ else
IPSEC_TOOLS_CONFIG_FLAGS+= --disable-stats
endif
-# At first check, if uClibc supports IPv6
-ifeq ($(shell grep -qs '__UCLIBC_HAS_IPV6__ 1' \
- $(STAGING_DIR)/include/bits/uClibc_config.h && echo IPV6), IPV6)
+ifeq ($(BR2_INET_IPV6),y)
ifeq ($(strip $(BR2_PACKAGE_IPSEC_TOOLS_IPV6)), y)
IPSEC_TOOLS_CONFIG_FLAGS+= --enable-ipv6
else
-IPSEC_TOOLS_CONFIG_FLAGS+= --disable-ipv6
+IPSEC_TOOLS_CONFIG_FLAGS+= $(DISABLE_IPV6)
endif
else # ignore user's choice if it doesn't
-IPSEC_TOOLS_CONFIG_FLAGS+= --disable-ipv6
+IPSEC_TOOLS_CONFIG_FLAGS+= $(DISABLE_IPV6)
endif
ifneq ($(strip $(BR2_PACKAGE_IPSEC_TOOLS_READLINE)), y)