summaryrefslogtreecommitdiffstats
path: root/package/intltool
diff options
context:
space:
mode:
Diffstat (limited to 'package/intltool')
-rw-r--r--package/intltool/Config.in6
-rw-r--r--package/intltool/intltook.mk16
2 files changed, 22 insertions, 0 deletions
diff --git a/package/intltool/Config.in b/package/intltool/Config.in
new file mode 100644
index 000000000..94b34f7c4
--- /dev/null
+++ b/package/intltool/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_INTLTOOL
+ bool "intltool"
+ help
+ Utility scripts for internationalizing XML
+
+ http://www.freedesktop.org/wiki/Software/intltool \ No newline at end of file
diff --git a/package/intltool/intltook.mk b/package/intltool/intltook.mk
new file mode 100644
index 000000000..746ebb1d5
--- /dev/null
+++ b/package/intltool/intltook.mk
@@ -0,0 +1,16 @@
+#############################################################
+#
+# intltool
+#
+#############################################################
+INTLTOOL_VERSION:=0.40.6
+INTLTOOL_SOURCE:=intltool-$(INTLTOOL_VERSION).tar.bz2
+INTLTOOL_SITE:=http://ftp.acc.umu.se/pub/GNOME/sources/intltool/0.40/
+
+HOST_INTLTOOL_DEPENDENCIES = host-libxml-parser-perl
+HOST_INTLTOOL_CONF_OPT = \
+ PERLLIB=$(HOST_DIR)/usr/lib/perl
+
+$(eval $(call AUTOTARGETS,package,intltool))
+$(eval $(call AUTOTARGETS,package,intltool,host))
+