summaryrefslogtreecommitdiffstats
path: root/package/gsl
diff options
context:
space:
mode:
Diffstat (limited to 'package/gsl')
-rw-r--r--package/gsl/gsl.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/package/gsl/gsl.mk b/package/gsl/gsl.mk
index 71968590a..65915916c 100644
--- a/package/gsl/gsl.mk
+++ b/package/gsl/gsl.mk
@@ -10,4 +10,17 @@ GSL_INSTALL_STAGING = YES
GSL_LICENSE = GPLv3
GSL_LICENSE_FILES = COPYING
+# uClibc pretends to have fenv support as it installs <fenv.h>, but in
+# practice, it only implements it for i386. Problem reported upstream
+# at: http://lists.busybox.net/pipermail/uclibc/2012-October/047067.html.
+# So we tell gsl that fenv related functions are not available in this
+# case.
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT)$(BR2_TOOLCHAIN_EXTERNAL_UCLIBC)$(BR2_TOOLCHAIN_CTNG_uClibc),y)
+ifneq ($(BR2_i386),y)
+GSL_CONF_ENV = \
+ ac_cv_have_decl_feenableexcept=no \
+ ac_cv_have_decl_fesettrapenable=no
+endif
+endif
+
$(eval $(autotools-package))