summaryrefslogtreecommitdiffstats
path: root/package/gnutls
diff options
context:
space:
mode:
Diffstat (limited to 'package/gnutls')
-rw-r--r--package/gnutls/Config.in8
-rw-r--r--package/gnutls/gnutls.mk14
2 files changed, 22 insertions, 0 deletions
diff --git a/package/gnutls/Config.in b/package/gnutls/Config.in
new file mode 100644
index 000000000..cedf120ee
--- /dev/null
+++ b/package/gnutls/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_GNUTLS
+ bool "gnutls"
+ select BR2_PACKAGE_LIBGCRYPT
+ help
+ GnuTLS is a secure communications library implementing the SSL
+ and TLS protocols and technologies around them.
+
+ http://www.gnu.org/software/gnutls/gnutls.html
diff --git a/package/gnutls/gnutls.mk b/package/gnutls/gnutls.mk
new file mode 100644
index 000000000..5f31e1e9d
--- /dev/null
+++ b/package/gnutls/gnutls.mk
@@ -0,0 +1,14 @@
+#############################################################
+#
+# gnutls
+#
+#############################################################
+
+GNUTLS_VERSION = 2.8.6
+GNUTLS_SOURCE = gnutls-$(GNUTLS_VERSION).tar.bz2
+GNUTLS_SITE = http://ftp.gnu.org/gnu/gnutls/
+GNUTLS_DEPENDENCIES = libgcrypt
+GNUTLS_CONF_OPT += --without-libgcrypt-prefix
+GNUTLS_INSTALL_STAGING = YES
+
+$(eval $(call AUTOTARGETS,package,gnutls))