summaryrefslogtreecommitdiffstats
path: root/package/fan-ctrl
diff options
context:
space:
mode:
Diffstat (limited to 'package/fan-ctrl')
-rw-r--r--package/fan-ctrl/Config.in10
-rw-r--r--package/fan-ctrl/fan-ctrl.mk30
2 files changed, 40 insertions, 0 deletions
diff --git a/package/fan-ctrl/Config.in b/package/fan-ctrl/Config.in
new file mode 100644
index 000000000..392904c9f
--- /dev/null
+++ b/package/fan-ctrl/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_FAN_CTRL
+ bool "fan-ctrl"
+ help
+ Fan-ctrl is a little daemon that controls the speed of one
+ or more system or CPU fans. It does so by monitoring
+ temperature inputs and selecting a fan speed from an array
+ of available speeds based on a set of temperature
+ thresholds.
+
+ http://fan-ctrl.sourceforge.net/
diff --git a/package/fan-ctrl/fan-ctrl.mk b/package/fan-ctrl/fan-ctrl.mk
new file mode 100644
index 000000000..b7bfa795f
--- /dev/null
+++ b/package/fan-ctrl/fan-ctrl.mk
@@ -0,0 +1,30 @@
+#############################################################
+#
+# fan-ctrl
+#
+#############################################################
+
+# no release, so grab .c file directly from viewvc
+FAN_CTRL_VERSION = 1.3
+FAN_CTRL_SOURCE = fan-ctrl.c?revision=$(FAN_CTRL_VERSION)
+FAN_CTRL_SITE = http://fan-ctrl.cvs.sourceforge.net/viewvc/fan-ctrl/fan-ctrl/
+FAN_CTRL_LICENSE = GPLv2+
+
+define FAN_CTRL_EXTRACT_CMDS
+ cp $(DL_DIR)/$(FAN_CTRL_SOURCE) $(@D)/fan-ctrl.c
+endef
+
+define FAN_CTRL_BUILD_CMDS
+ $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) \
+ $(@D)/fan-ctrl.c -o $(@D)/fan-ctrl
+endef
+
+define FAN_CTRL_INSTALL_TARGET_CMDS
+ install -D -m 755 $(@D)/fan-ctrl $(TARGET_DIR)/usr/sbin/fan-ctrl
+endef
+
+define FAN_CTRL_UNINSTALL_TARGET_CMDS
+ rm -f $(TARGET_DIR)/usr/sbin/fan-ctrl
+endef
+
+$(eval $(generic-package))