summaryrefslogtreecommitdiffstats
path: root/package/dropbear
diff options
context:
space:
mode:
Diffstat (limited to 'package/dropbear')
-rw-r--r--package/dropbear/Config.in8
-rw-r--r--package/dropbear/dropbear.mk4
2 files changed, 12 insertions, 0 deletions
diff --git a/package/dropbear/Config.in b/package/dropbear/Config.in
index 20469f8b2..e47ba4545 100644
--- a/package/dropbear/Config.in
+++ b/package/dropbear/Config.in
@@ -5,3 +5,11 @@ config BR2_PACKAGE_DROPBEAR
A small SSH 2 server designed for small memory environments.
http://matt.ucc.asn.au/dropbear/dropbear.html
+
+config BR2_PACKAGE_DROPBEAR_DISABLE_REVERSEDNS
+ bool "disable reverse DNS lookups"
+ depends on BR2_PACKAGE_DROPBEAR
+ help
+ Disable reverse DNS lookups on connection. This can be handy
+ on systems without working DNS, as connections otherwise
+ stall until DNS times out.
diff --git a/package/dropbear/dropbear.mk b/package/dropbear/dropbear.mk
index c73525b04..ec678d7e9 100644
--- a/package/dropbear/dropbear.mk
+++ b/package/dropbear/dropbear.mk
@@ -21,6 +21,10 @@ $(eval $(call AUTOTARGETS,package,dropbear))
$(DROPBEAR_HOOK_POST_EXTRACT):
$(SED) 's,^#define XAUTH_COMMAND.*/xauth,#define XAUTH_COMMAND "/usr/bin/xauth,g' $(DROPBEAR_DIR)/options.h
+ifeq ($(BR2_PACKAGE_DROPBEAR_DISABLE_REVERSEDNS),y)
+ $(SED) 's,^#define DO_HOST_LOOKUP.*,/* #define DO_HOST_LOOKUP */,' \
+ $(DROPBEAR_DIR)/options.h
+endif
touch $@
$(DROPBEAR_TARGET_INSTALL_TARGET):