summaryrefslogtreecommitdiffstats
path: root/package/ctorrent/ctorrent.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/ctorrent/ctorrent.mk')
-rw-r--r--package/ctorrent/ctorrent.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/ctorrent/ctorrent.mk b/package/ctorrent/ctorrent.mk
index 256088180..aa2215315 100644
--- a/package/ctorrent/ctorrent.mk
+++ b/package/ctorrent/ctorrent.mk
@@ -6,6 +6,12 @@
CTORRENT_VERSION:=dnh3.3.2
CTORRENT_SOURCE:=ctorrent-$(CTORRENT_VERSION).tar.gz
CTORRENT_SITE:=http://www.rahul.net/dholmes/ctorrent/
-CTORRENT_CONF_OPT:=--with-ssl=no
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+CTORRENT_CONF_OPT+=--with-ssl=yes
+CTORRENT_DEPENDENCIES+=openssl
+else
+CTORRENT_CONF_OPT+=--with-ssl=no
+endif
$(eval $(call AUTOTARGETS,package,ctorrent))