summaryrefslogtreecommitdiffstats
path: root/package/bustle
diff options
context:
space:
mode:
Diffstat (limited to 'package/bustle')
-rw-r--r--package/bustle/Config.in22
-rw-r--r--package/bustle/bustle.mk23
2 files changed, 45 insertions, 0 deletions
diff --git a/package/bustle/Config.in b/package/bustle/Config.in
new file mode 100644
index 000000000..2a2a2c1d6
--- /dev/null
+++ b/package/bustle/Config.in
@@ -0,0 +1,22 @@
+config BR2_PACKAGE_BUSTLE
+ bool "bustle"
+ select BR2_PACKAGE_LIBPCAP
+ select BR2_PACKAGE_LIBGLIB2
+ depends on BR2_USE_WCHAR # libglib2
+ depends on BR2_PACKAGE_DBUS # runtime
+ help
+ Bustle is a better dbus-monitor! It records and draws
+ sequence diagrams of D-Bus activity, showing signal
+ emissions, method calls and their corresponding returns,
+ with timestamps for each individual event and the duration
+ of each method call. This can help you check for unwanted
+ D-Bus traffic, and pinpoint why your D-Bus-based application
+ isn't performing as well as you like.
+
+ This only installs the command line bustle-pcap tool, not
+ the graphical viewer.
+
+ http://www.willthompson.co.uk/bustle/
+
+comment "bustle requires a toolchain with WCHAR support"
+ depends on !BR2_USE_WCHAR
diff --git a/package/bustle/bustle.mk b/package/bustle/bustle.mk
new file mode 100644
index 000000000..88d49b62e
--- /dev/null
+++ b/package/bustle/bustle.mk
@@ -0,0 +1,23 @@
+#############################################################
+#
+# bustle
+#
+#############################################################
+
+BUSTLE_VERSION = 0.4.2
+BUSTLE_SITE = http://www.willthompson.co.uk/bustle/releases/$(BUSTLE_VERSION)/
+BUSTLE_LICENSE = LGPLv2.1+
+BUSTLE_LICENSE_FILES = LICENSE
+BUSTLE_DEPENDENCIES = libglib2 libpcap host-pkgconf
+
+define BUSTLE_BUILD_CMDS
+ PATH=$(TARGET_PATH) $(MAKE) $(TARGET_CONFIGURE_OPTS) \
+ PCAP_FLAGS='-lpcap' -C $(@D) dist/build/bustle-pcap
+endef
+
+define BUSTLE_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 0755 -D $(@D)/dist/build/bustle-pcap \
+ $(TARGET_DIR)/usr/bin/bustle-pcap
+endef
+
+$(eval $(generic-package))