summaryrefslogtreecommitdiffstats
path: root/package/boost
diff options
context:
space:
mode:
Diffstat (limited to 'package/boost')
-rw-r--r--package/boost/Config.in4
-rw-r--r--package/boost/boost.mk6
2 files changed, 7 insertions, 3 deletions
diff --git a/package/boost/Config.in b/package/boost/Config.in
index 5c65b2fbf..912717ad3 100644
--- a/package/boost/Config.in
+++ b/package/boost/Config.in
@@ -9,8 +9,6 @@ config BR2_PACKAGE_BOOST
# that unfortunately doesn't work. Until someone fixes that,
# let's depend on threads.
depends on BR2_TOOLCHAIN_HAS_THREADS
- select BR2_PACKAGE_BZIP2
- select BR2_PACKAGE_ZLIB
help
A general purpose C++ library
@@ -43,6 +41,8 @@ config BR2_PACKAGE_BOOST_GRAPH_PARALLEL
config BR2_PACKAGE_BOOST_IOSTREAMS
bool "boost-iostreams"
+ select BR2_PACKAGE_BZIP2
+ select BR2_PACKAGE_ZLIB
config BR2_PACKAGE_BOOST_LOCALE
depends on BR2_USE_WCHAR
diff --git a/package/boost/boost.mk b/package/boost/boost.mk
index 57d021ae4..ce729901a 100644
--- a/package/boost/boost.mk
+++ b/package/boost/boost.mk
@@ -12,7 +12,7 @@ BOOST_INSTALL_STAGING = YES
TARGET_CC_VERSION = $(shell $(TARGET_CC) -dumpversion)
-BOOST_DEPENDENCIES = bzip2 zlib
+BOOST_DEPENDENCIES =
BOOST_FLAGS =
@@ -48,6 +48,10 @@ else
BOOST_FLAGS += --without-icu
endif
+ifeq ($(BR2_PACKAGE_BOOST_IOSTREAMS),y)
+BOOST_DEPENDENCIES += bzip2 zlib
+endif
+
BOOST_OPT += toolset=gcc \
threading=multi \
variant=$(if $(BR2_ENABLE_DEBUG),debug,release) \