summaryrefslogtreecommitdiffstats
path: root/package/bonnie/bonnie.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/bonnie/bonnie.mk')
-rw-r--r--package/bonnie/bonnie.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/bonnie/bonnie.mk b/package/bonnie/bonnie.mk
new file mode 100644
index 000000000..9a6188fa4
--- /dev/null
+++ b/package/bonnie/bonnie.mk
@@ -0,0 +1,18 @@
+#
+# bonnie++
+#
+
+BONNIE_VERSION = 1.03e
+BONNIE_SOURCE = bonnie++-$(BONNIE_VERSION).tgz
+BONNIE_SITE = http://www.coker.com.au/bonnie++/
+
+define BONNIE_INSTALL_TARGET_CMDS
+ install -D -m 755 $(@D)/bonnie++ $(TARGET_DIR)/usr/sbin/bonnie++
+ install -D -m 755 $(@D)/zcav $(TARGET_DIR)/usr/sbin/zcav
+endef
+
+define BONNIE_UNINSTALL_TARGET_CMDS
+ rm -f $(TARGET_DIR)/usr/sbin/bonnie++ $(TARGET_DIR)/usr/sbin/zcav
+endef
+
+$(eval $(call AUTOTARGETS,package,bonnie))