summaryrefslogtreecommitdiffstats
path: root/package/bison/bison.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/bison/bison.mk')
-rw-r--r--package/bison/bison.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/bison/bison.mk b/package/bison/bison.mk
index 2a764e0eb..cdc78eadd 100644
--- a/package/bison/bison.mk
+++ b/package/bison/bison.mk
@@ -58,7 +58,8 @@ $(TARGET_DIR)/$(BISON_TARGET_BINARY): $(BISON_DIR)/$(BISON_BINARY)
bison: uclibc $(TARGET_DIR)/$(BISON_TARGET_BINARY)
bison-clean:
- $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(BISON_DIR) uninstall
+ -$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(BISON_DIR) uninstall
+ rm -f $(TARGET_DIR)/$(BISON_TARGET_BINARY)
-$(MAKE) -C $(BISON_DIR) clean
bison-dirclean: