summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index a449089c1..9ba6e8cf4 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -7,11 +7,12 @@ endif
HOSTMAKE :=$(shell which $(HOSTMAKE) || type -p $(HOSTMAKE) || echo make)
# If BR2_LEVEL is 0, scale the maximum concurrency with the number of
-# CPUs. A coefficient of 2 is used in order to keep processors busy
+# CPUs. An additional job is used in order to keep processors busy
# while waiting on I/O.
+# If the number of processors is not available, assume one.
ifeq ($(BR2_JLEVEL),0)
PARALLEL_JOBS:=$(shell echo \
- $$((2 * `getconf _NPROCESSORS_ONLN 2>/dev/null || echo 1`)))
+ $$((1 + `getconf _NPROCESSORS_ONLN 2>/dev/null || echo 1`)))
else
PARALLEL_JOBS:=$(BR2_JLEVEL)
endif