summaryrefslogtreecommitdiffstats
path: root/linux
diff options
context:
space:
mode:
Diffstat (limited to 'linux')
-rw-r--r--linux/Config.ext.in12
-rw-r--r--linux/linux-ext-ocf-linux.mk25
2 files changed, 0 insertions, 37 deletions
diff --git a/linux/Config.ext.in b/linux/Config.ext.in
index a68cbe921..172fa76c7 100644
--- a/linux/Config.ext.in
+++ b/linux/Config.ext.in
@@ -23,18 +23,6 @@ config BR2_LINUX_KERNEL_EXT_XENOMAI_ADEOS_PATCH
Download it at http://download.gna.org/adeos/patches/v2.6/$(ARCH)/
and verify that your kernel version in buildroot matches.
-# ocf-linux
-config BR2_LINUX_KERNEL_EXT_OCF_LINUX
- bool "Open Cryptographic Framework (OCF)"
- select BR2_PACKAGE_OCF_LINUX
- help
- OCF-Linux Kernel part.
-
- Select this option to patch your kernel with OCF for
- hardware-accelerated crypto support for available drivers.
- Some libraries need to also have OCF enabled for them,
- for example OpenSSL.
-
# RTAI
config BR2_LINUX_KERNEL_EXT_RTAI
bool "RTAI Real-time patch"
diff --git a/linux/linux-ext-ocf-linux.mk b/linux/linux-ext-ocf-linux.mk
deleted file mode 100644
index 1a601d58c..000000000
--- a/linux/linux-ext-ocf-linux.mk
+++ /dev/null
@@ -1,25 +0,0 @@
-##################################################
-# Linux OCF extension
-#
-# Patch the linux kernel with OCF
-##################################################
-
-ifeq ($(BR2_LINUX_KERNEL_EXT_OCF_LINUX),y)
-LINUX_DEPENDENCIES += ocf-linux
-
-# Prepare kernel patch
-# The linux-3.2.1.patch is just the main inclusion, most of the code
-# resides in the ocf/ subdir.
-# It works for older kernel versions.
-# Run tested from 2.6.38+ and build tested from 2.6.35+
-define OCF_LINUX_PREPARE_KERNEL
- support/scripts/apply-patches.sh $(LINUX_DIR) \
- $(OCF_LINUX_DIR)/patches/ linux-3.2.1-ocf.patch ; \
- grep -q __mix_pool_bytes $(LINUX_DIR)/drivers/char/random.c && \
- $(SED) 's:wordcount\*4:&, NULL:' $(LINUX_DIR)/drivers/char/random.c ; \
- cp -rf $(OCF_LINUX_DIR)/ocf $(LINUX_DIR)/crypto/ocf ;
-endef
-
-LINUX_PRE_PATCH_HOOKS += OCF_LINUX_PREPARE_KERNEL
-
-endif #BR2_LINUX_EXT_OCF_LINUX