summaryrefslogtreecommitdiffstats
path: root/fs
diff options
context:
space:
mode:
Diffstat (limited to 'fs')
-rw-r--r--fs/squashfs/squashfs.mk12
1 files changed, 10 insertions, 2 deletions
diff --git a/fs/squashfs/squashfs.mk b/fs/squashfs/squashfs.mk
index f11ba2090..a9041828d 100644
--- a/fs/squashfs/squashfs.mk
+++ b/fs/squashfs/squashfs.mk
@@ -8,10 +8,18 @@ ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4),y)
ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs
else
ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs3
+
+ifeq ($(BR2_ENDIAN),"BIG")
+ROOTFS_SQUASHF_ARGS=-be
+else
+ROOTFS_SQUASHFS_ARGS=-le
+endif
+
endif
define ROOTFS_SQUASHFS_CMD
- $(HOST_DIR)/usr/bin/mksquashfs $(TARGET_DIR) $$@ -noappend
+ $(HOST_DIR)/usr/bin/mksquashfs $(TARGET_DIR) $$@ -noappend \
+ $(ROOTFS_SQUASHFS_ARGS)
endef
-$(eval $(call ROOTFS_TARGET,squashfs)) \ No newline at end of file
+$(eval $(call ROOTFS_TARGET,squashfs))