summaryrefslogtreecommitdiffstats
path: root/Makefile.legacy
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.legacy')
-rw-r--r--Makefile.legacy13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.legacy b/Makefile.legacy
new file mode 100644
index 000000000..2e015a1e3
--- /dev/null
+++ b/Makefile.legacy
@@ -0,0 +1,13 @@
+#
+# Makefile.legacy - support for backward compatibility
+#
+# This file contains placeholders to detect backward-compatibility problems.
+# When a buildroot "API" feature is being deprecated, a rule should be added
+# here that issues an error when the old feature is used.
+#
+# This file is not included if BR2_DEPRECATED is selected, so it is possible
+# to bypass the errors (although that's usually a bad idea).
+
+ifeq ($(BR2_LEGACY),y)
+$(error "You have legacy configuration in your .config! Please check your configuration.")
+endif