summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/dbus/dbus.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/dbus/dbus.mk b/package/dbus/dbus.mk
index b7cc37820..ec42874b6 100644
--- a/package/dbus/dbus.mk
+++ b/package/dbus/dbus.mk
@@ -18,11 +18,16 @@ DBUS_CONF_OPT = --with-dbus-user=dbus \
--disable-xml-docs \
--disable-doxygen-docs \
--disable-static \
- --enable-dnotify \
+ --disable-dnotify \
--localstatedir=/var \
--with-system-socket=/var/run/dbus/system_bus_socket \
--with-system-pid-file=/var/run/messagebus.pid
+ifeq ($(BR2_microblaze),y)
+# microblaze toolchain doesn't provide inotify_rm_* but does have sys/inotify.h
+DBUS_CONF_OPT += --disable-inotify
+endif
+
ifeq ($(BR2_DBUS_EXPAT),y)
DBUS_CONF_OPT += --with-xml=expat
DBUS_DEPENDENCIES += expat