summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 97804ff78..5b690f017 100644
--- a/Makefile
+++ b/Makefile
@@ -429,7 +429,9 @@ endif
$(BUILD_DIR)/.root:
mkdir -p $(TARGET_DIR)
- rsync -au --exclude=.empty --exclude=CVS --exclude=.svn --exclude='*~' \
+ rsync -a \
+ --exclude .empty --exclude .svn --exclude .git \
+ --exclude .hg --exclude=CVS --exclude '*~' \
$(TARGET_SKELETON)/ $(TARGET_DIR)/
cp support/misc/target-dir-warning.txt $(TARGET_DIR_WARNING_FILE)
touch $@
@@ -505,7 +507,7 @@ endif
$(call MESSAGE,"Copying overlay $(d)"); \
rsync -a \
--exclude .empty --exclude .svn --exclude .git \
- --exclude .hg --exclude '*~' \
+ --exclude .hg --exclude=CVS --exclude '*~' \
$(d)/ $(TARGET_DIR)$(sep))
@$(foreach s, $(call qstrip,$(BR2_ROOTFS_POST_BUILD_SCRIPT)), \