summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--toolchain/Config.in.23
-rw-r--r--toolchain/external-toolchain/Config.in23
3 files changed, 12 insertions, 16 deletions
diff --git a/Makefile b/Makefile
index d44630215..c6e683a1d 100644
--- a/Makefile
+++ b/Makefile
@@ -202,7 +202,7 @@ PREFERRED_LIB_FLAGS:=--enable-static --enable-shared
ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
BASE_TARGETS:=uclibc-configured binutils cross_compiler uclibc-target-utils kernel-headers
else
-BASE_TARGETS:=uclibc kernel-headers
+BASE_TARGETS:=uclibc
endif
TARGETS:=
diff --git a/toolchain/Config.in.2 b/toolchain/Config.in.2
index d00faab40..c1733e96e 100644
--- a/toolchain/Config.in.2
+++ b/toolchain/Config.in.2
@@ -1,8 +1,7 @@
#
-source "toolchain/kernel-headers/Config.in"
-
if BR2_TOOLCHAIN_SOURCE
+source "toolchain/kernel-headers/Config.in"
source "toolchain/uClibc/Config.in"
source "toolchain/binutils/Config.in"
source "toolchain/gcc/Config.in"
diff --git a/toolchain/external-toolchain/Config.in b/toolchain/external-toolchain/Config.in
index e73090af0..805d21a2c 100644
--- a/toolchain/external-toolchain/Config.in
+++ b/toolchain/external-toolchain/Config.in
@@ -69,32 +69,29 @@ choice
endchoice
config BR2_LARGEFILE
- bool "Enable large file (files > 2 GB) support?"
+ bool "Toolchain supports large files (> 2 GB) ?"
depends on !BR2_cris
default y
help
- Enable large file (files > 2 GB) support
+ Set this option if the external toolchain supports large
+ files (> 2 GB)
+
config BR2_INET_IPV6
- bool "Enable IPv6"
+ bool "Toolchain supports IPv6 ?"
help
- Enable IPv6.
+ Set this option if the external toolchain supports IPv6.
config BR2_INET_RPC
- bool "Enable RPC"
+ bool "Toolchain supports RPC ?"
help
- Enable RPC. RPC support is needed for nfs.
+ Set this option if the external toolchain supports RPC.
config BR2_SOFT_FLOAT
- bool "Use software floating point by default"
+ bool "Toolchain supports soft float ?"
depends on BR2_arm || BR2_armeb || BR2_mips || BR2_mipsel || BR2_powerpc
help
- If your target CPU does not have a Floating Point Unit (FPU) or a
- kernel FPU emulator, but you still wish to support floating point
- functions, then everything will need to be compiled with soft
- floating point support (-msoft-float).
-
- Most people will answer N.
+ Set this option if the external toolchain supports soft float.
config BR2_TARGET_OPTIMIZATION
string "Target Optimizations"