summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/microperl/microperl.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/microperl/microperl.mk b/package/microperl/microperl.mk
index e8d327479..5a41f384d 100644
--- a/package/microperl/microperl.mk
+++ b/package/microperl/microperl.mk
@@ -82,7 +82,10 @@ ifneq ($(MICROPERL_MODS),)
done; \
)
endif
- cp -dpf $(MICROPERL_DIR)/microperl $(TARGET_DIR)/usr/bin/microperl
+ cp -dpf $(MICROPERL_DIR)/microperl $@
+ifneq ($(BR2_STRIP_none),y)
+ $(STRIPCMD) $(STRIP_STRIP_ALL) $@
+endif
(cd $(TARGET_DIR)/usr/bin; rm -f perl; ln -s microperl perl;)
microperl: uclibc $(TARGET_DIR)/usr/bin/microperl