summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-06-23 16:20:02 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-06-23 21:55:42 +0200
commit88d9d17d975e97edde093f441b42d35f8a178aca (patch)
tree143c02b25da4a0f31b248f86625c6bb69be36592 /toolchain
parent2f2bf6a800d585ea381e09eec148844a7135ac53 (diff)
downloadbuildroot-novena-88d9d17d975e97edde093f441b42d35f8a178aca.tar.gz
buildroot-novena-88d9d17d975e97edde093f441b42d35f8a178aca.zip
toolchain-external: bump to Linaro ARM 2013.06
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/toolchain-external/Config.in22
-rw-r--r--toolchain/toolchain-external/ext-tool.mk6
2 files changed, 14 insertions, 14 deletions
diff --git a/toolchain/toolchain-external/Config.in b/toolchain/toolchain-external/Config.in
index 94b8158a9..ebe9fcd30 100644
--- a/toolchain/toolchain-external/Config.in
+++ b/toolchain/toolchain-external/Config.in
@@ -3,8 +3,8 @@ if BR2_TOOLCHAIN_EXTERNAL
choice
prompt "Toolchain"
-config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_05
- bool "Linaro 2013.05"
+config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_06
+ bool "Linaro 2013.06"
depends on BR2_arm
depends on BR2_GCC_TARGET_ARCH = "armv7-a"
depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
@@ -14,7 +14,7 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_05
select BR2_HOSTARCH_NEEDS_IA32_LIBS
help
Linaro toolchain for the ARM architecture. It uses Linaro
- GCC 2013.05 (based on gcc 4.8), Linaro GDB 2013.05 (based on
+ GCC 2013.06 (based on gcc 4.8), Linaro GDB 2013.06 (based on
GDB 7.6), eglibc 2.15. It generates code that runs on all
Cortex-A profile devices, but tuned for the Cortex-A9. The
code generated is Thumb 2, with the hard floating point
@@ -22,8 +22,8 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_05
To use this toolchain, you must disable soft float usage.
-config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_04
- bool "Linaro 2013.04"
+config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_05
+ bool "Linaro 2013.05"
depends on BR2_arm
depends on BR2_GCC_TARGET_ARCH = "armv7-a"
depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
@@ -33,16 +33,16 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_04
select BR2_HOSTARCH_NEEDS_IA32_LIBS
help
Linaro toolchain for the ARM architecture. It uses Linaro
- GCC 2013.04 (based on gcc 4.7), Linaro GDB 2012.12 (based on
- GDB 7.5), eglibc 2.15. It generates code that runs on all
+ GCC 2013.05 (based on gcc 4.8), Linaro GDB 2013.05 (based on
+ GDB 7.6), eglibc 2.15. It generates code that runs on all
Cortex-A profile devices, but tuned for the Cortex-A9. The
code generated is Thumb 2, with the hard floating point
calling convention, and uses the VFPv3-D16 FPU instructions.
To use this toolchain, you must disable soft float usage.
-config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_03
- bool "Linaro 2013.03"
+config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_04
+ bool "Linaro 2013.04"
depends on BR2_arm
depends on BR2_GCC_TARGET_ARCH = "armv7-a"
depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
@@ -52,7 +52,7 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_03
select BR2_HOSTARCH_NEEDS_IA32_LIBS
help
Linaro toolchain for the ARM architecture. It uses Linaro
- GCC 2013.03 (based on gcc 4.7), Linaro GDB 2012.12 (based on
+ GCC 2013.04 (based on gcc 4.7), Linaro GDB 2012.12 (based on
GDB 7.5), eglibc 2.15. It generates code that runs on all
Cortex-A profile devices, but tuned for the Cortex-A9. The
code generated is Thumb 2, with the hard floating point
@@ -777,9 +777,9 @@ config BR2_TOOLCHAIN_EXTERNAL_CUSTOM_PREFIX
config BR2_TOOLCHAIN_EXTERNAL_PREFIX
string
+ default "arm-linux-gnueabihf" if BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_06
default "arm-linux-gnueabihf" if BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_05
default "arm-linux-gnueabihf" if BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_04
- default "arm-linux-gnueabihf" if BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_03
default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201109
default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201203
default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201305
diff --git a/toolchain/toolchain-external/ext-tool.mk b/toolchain/toolchain-external/ext-tool.mk
index e5dc8ed41..2b0b23ec8 100644
--- a/toolchain/toolchain-external/ext-tool.mk
+++ b/toolchain/toolchain-external/ext-tool.mk
@@ -218,15 +218,15 @@ define TOOLCHAIN_EXTERNAL_FIXUP_CMDS
mv $(@D)/arago-2011.09/armv5te/* $(@D)/
rm -rf $(@D)/arago-2011.09/
endef
-else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_03),y)
-TOOLCHAIN_EXTERNAL_SITE=https://releases.linaro.org/13.03/components/toolchain/binaries/
-TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-4.7-2013.03-20130313_linux.tar.bz2
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_04),y)
TOOLCHAIN_EXTERNAL_SITE=https://releases.linaro.org/13.04/components/toolchain/binaries/
TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-4.7-2013.04-20130415_linux.tar.xz
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_05),y)
TOOLCHAIN_EXTERNAL_SITE=https://releases.linaro.org/13.05/components/toolchain/binaries/
TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-4.8-2013.05_linux.tar.xz
+else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_06),y)
+TOOLCHAIN_EXTERNAL_SITE=https://releases.linaro.org/13.06/components/toolchain/binaries/
+TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-4.8-2013.06_linux.tar.xz
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201203),y)
TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/public/gnu_toolchain/mips-linux-gnu/
TOOLCHAIN_EXTERNAL_SOURCE=mips-2012.03-63-mips-linux-gnu-i686-pc-linux-gnu.tar.bz2