summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-06-30 21:28:54 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-07-03 08:28:15 +0200
commit1f6d92d2ce2fee794080505e0c6536b78cf252ea (patch)
tree65eb18538a3c3c0db377f0fd86fd60348882ecb5 /toolchain
parent598ade90a8a4eb6036499d8d81589aadd69d9f43 (diff)
downloadbuildroot-novena-1f6d92d2ce2fee794080505e0c6536b78cf252ea.tar.gz
buildroot-novena-1f6d92d2ce2fee794080505e0c6536b78cf252ea.zip
toolchain/gcc: remove dead code related to host binary stripping
The GCC_STRIP_HOST_BINARIES variable was always defined to 'nope', which means that the host binaries were never stripped. Get rid of the corresponding code, which is not in use. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk5
1 files changed, 0 insertions, 5 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 92361e56e..79a01250e 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -43,7 +43,6 @@ GCC_SOURCE:=gcc-$(GCC_VERSION).tar.bz2
GCC_PATCH_DIR:=toolchain/gcc/$(GCC_VERSION)
GCC_DIR:=$(TOOLCHAIN_DIR)/gcc-$(GCC_VERSION)
GCC_CAT:=$(BZCAT)
-GCC_STRIP_HOST_BINARIES:=nope
GCC_SRC_DIR:=$(GCC_DIR)
# Branding works on >= 4.3
@@ -472,10 +471,6 @@ $(GCC_BUILD_DIR3)/.installed: $(GCC_BUILD_DIR3)/.compiled
rmdir "$(STAGING_DIR)/lib64"; \
rm "$(STAGING_DIR)/usr/$(GNU_TARGET_NAME)/lib64";\
fi
- # Strip the host binaries
-ifeq ($(GCC_STRIP_HOST_BINARIES),true)
- strip --strip-all -R .note -R .comment $(filter-out %-gccbug %-embedspu,$(wildcard $(HOST_DIR)/usr/bin/$(GNU_TARGET_NAME)-*))
-endif
# Make sure we have 'cc'.
if [ ! -e $(HOST_DIR)/usr/bin/$(GNU_TARGET_NAME)-cc ]; then \
ln -snf $(GNU_TARGET_NAME)-gcc \