summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-27 18:21:44 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-27 18:23:32 +0200
commitfed6a2a6ea884630a3723d2a49579e63e87ffd57 (patch)
treec14f9e855b8c5791d87ec5e43a5a106ad2aa35cc /toolchain
parent4e62eeed193e2c90bfbca52a28efaa1c2f5cd327 (diff)
downloadbuildroot-novena-fed6a2a6ea884630a3723d2a49579e63e87ffd57.tar.gz
buildroot-novena-fed6a2a6ea884630a3723d2a49579e63e87ffd57.zip
target-gcc: remove useless copies of gcc
When doing the "make install" of target, three identical copies of gcc are installed in $(TARGET_DIR)/usr/bin: 039adcc582c365f12ba6fc5f96098128 arm-unknown-linux-uclibcgnueabi-gcc 039adcc582c365f12ba6fc5f96098128 arm-unknown-linux-uclibcgnueabi-gcc-4.3.5 039adcc582c365f12ba6fc5f96098128 gcc This patch removes the first two copies and keeps only the common "gcc" one. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 5dec86c87..9720ed39b 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -445,6 +445,9 @@ $(TARGET_DIR)/usr/bin/gcc: $(GCC_BUILD_DIR3)/.compiled
# Remove broken specs file (cross compile flag is set).
rm -f $(TARGET_DIR)/usr/$(GCC_LIB_SUBDIR)/specs
+ # Remove useless copies of gcc
+ rm -f $(TARGET_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-gcc*
+
# Work around problem of missing syslimits.h
if [ ! -f $(TARGET_DIR)/usr/$(GCC_LIB_SUBDIR)/$(GCC_INCLUDE_DIR)/syslimits.h ]; then \
echo "warning: working around missing syslimits.h"; \