summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-02-23 21:27:28 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-02-23 21:27:28 +0100
commit4f05a61b33e5d87f23837109fb0dd538a5bd5d62 (patch)
treef1b375060271ec5fd5da6fe89955b11b7c238fae /toolchain
parent52fcd86f2ba1249e74ed04ef39cb3cbea16024c7 (diff)
parentf08e9eea1b70f057cc0a3efa18b2acb4faea4abe (diff)
downloadbuildroot-novena-4f05a61b33e5d87f23837109fb0dd538a5bd5d62.tar.gz
buildroot-novena-4f05a61b33e5d87f23837109fb0dd538a5bd5d62.zip
Merge branch 'misc-fixes5' of git://git.busybox.net/~tpetazzoni/git/buildroot
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/ccache/ccache.mk3
-rwxr-xr-xtoolchain/dependencies/dependencies.sh2
2 files changed, 1 insertions, 4 deletions
diff --git a/toolchain/ccache/ccache.mk b/toolchain/ccache/ccache.mk
index c98937d37..8e414b27b 100644
--- a/toolchain/ccache/ccache.mk
+++ b/toolchain/ccache/ccache.mk
@@ -163,9 +163,6 @@ $(CCACHE_DIR2)/$(CCACHE_BINARY): $(CCACHE_DIR2)/.configured
$(TARGET_DIR)/$(CCACHE_TARGET_BINARY): $(CCACHE_DIR2)/$(CCACHE_BINARY)
$(MAKE) DESTDIR=$(TARGET_DIR) -C $(CCACHE_DIR2) install
-ifneq ($(BR2_HAVE_MANPAGES),y)
- rm -rf $(TARGET_DIR)/usr/man
-endif
# put a bunch of symlinks into /bin, since that is earlier
# in the default PATH than /usr/bin where gcc lives
(cd $(TARGET_DIR)/bin; \
diff --git a/toolchain/dependencies/dependencies.sh b/toolchain/dependencies/dependencies.sh
index f5b26214d..146e08023 100755
--- a/toolchain/dependencies/dependencies.sh
+++ b/toolchain/dependencies/dependencies.sh
@@ -122,7 +122,7 @@ if ! $SHELL --version 2>&1 | grep -q '^GNU bash'; then
fi;
# Check that a few mandatory programs are installed
-for prog in awk bison flex msgfmt makeinfo patch ; do
+for prog in awk bison flex msgfmt makeinfo patch gzip bzip2 perl ; do
if ! which $prog > /dev/null ; then
/bin/echo -e "\nYou must install '$prog' on your build machine";
if test $prog = "makeinfo" ; then