summaryrefslogtreecommitdiffstats
path: root/toolchain/toolchain-external
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-10-25 22:20:25 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-10-26 13:12:33 +0200
commit94ca09c4725c423cda5f9a97039158fa79329c02 (patch)
treeed37002a4c9698010cfa0d5d21bbd359e28806df /toolchain/toolchain-external
parent5a61fbd82394f9bc9317535b717a2e1dd51dea7d (diff)
downloadbuildroot-novena-94ca09c4725c423cda5f9a97039158fa79329c02.tar.gz
buildroot-novena-94ca09c4725c423cda5f9a97039158fa79329c02.zip
toolchain-external: add support for Linaro 2012.10 toolchain
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/toolchain-external')
-rw-r--r--toolchain/toolchain-external/Config.in17
-rw-r--r--toolchain/toolchain-external/ext-tool.mk3
2 files changed, 20 insertions, 0 deletions
diff --git a/toolchain/toolchain-external/Config.in b/toolchain/toolchain-external/Config.in
index 105fb2a26..7a9ec1db8 100644
--- a/toolchain/toolchain-external/Config.in
+++ b/toolchain/toolchain-external/Config.in
@@ -3,6 +3,22 @@ if BR2_TOOLCHAIN_EXTERNAL
choice
prompt "Toolchain"
+config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_10
+ bool "Linaro 2012.10"
+ depends on BR2_arm
+ depends on BR2_cortex_a8 || BR2_cortex_a9
+ select BR2_TOOLCHAIN_EXTERNAL_GLIBC
+ select BR2_INSTALL_LIBSTDCPP
+ help
+ Linaro toolchain for the ARM architecture. It uses Linaro
+ GCC 2012.10 (based on gcc 4.7), Linaro GDB 2012.10 (based on
+ GDB 7.5), eglibc 2.15. It generates code that runs on all
+ Cortex-A profile devices, but tuned for the Cortex-A9. The
+ code generated is Thumb 2, with the hard floating point
+ calling convention, and uses the VFPv3-D16 FPU instructions.
+
+ To use this toolchain, you must disable soft float usage.
+
config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_09
bool "Linaro 2012.09"
depends on BR2_arm
@@ -637,6 +653,7 @@ config BR2_TOOLCHAIN_EXTERNAL_PREFIX
default "arm-linux-gnueabihf" if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_07
default "arm-linux-gnueabihf" if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_08
default "arm-linux-gnueabihf" if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_09
+ default "arm-linux-gnueabihf" if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_10
default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM2010Q1
default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201009
default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201103
diff --git a/toolchain/toolchain-external/ext-tool.mk b/toolchain/toolchain-external/ext-tool.mk
index 43d747cad..a7e4ab624 100644
--- a/toolchain/toolchain-external/ext-tool.mk
+++ b/toolchain/toolchain-external/ext-tool.mk
@@ -205,6 +205,9 @@ TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-2012.08-20120827_linux.
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_09),y)
TOOLCHAIN_EXTERNAL_SITE=https://launchpad.net/linaro-toolchain-binaries/trunk/2012.09/+download/
TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-2012.09-20120921_linux.tar.bz2
+else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_10),y)
+TOOLCHAIN_EXTERNAL_SITE=https://launchpad.net/linaro-toolchain-binaries/trunk/2012.10/+download/
+TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-4.7-2012.10-20121022_linux.tar.bz2
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS44),y)
TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/sgpp/lite/mips/portal/package7401/public/mips-linux-gnu/
TOOLCHAIN_EXTERNAL_SOURCE=mips-4.4-303-mips-linux-gnu-i686-pc-linux-gnu.tar.bz2