summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2009-10-07 22:08:24 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-10-07 22:13:06 +0200
commit10eaccc2332b0366b10fbe7f0c4dc6c12332e130 (patch)
tree251ccba32ce53c08866edebc372482af953f79f4 /target
parent076e720240edcfbad1881dffe83bd253d66d0075 (diff)
downloadbuildroot-novena-10eaccc2332b0366b10fbe7f0c4dc6c12332e130.tar.gz
buildroot-novena-10eaccc2332b0366b10fbe7f0c4dc6c12332e130.zip
allow menuconfig without a LINUX26_KCONFIG file
Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'target')
-rw-r--r--target/linux/Makefile.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/Makefile.in b/target/linux/Makefile.in
index cf430d96b..c4962bd3f 100644
--- a/target/linux/Makefile.in
+++ b/target/linux/Makefile.in
@@ -202,7 +202,11 @@ $(TARGET_DIR)/lib/modules/$(LINUX26_VERSION)/modules.dep: $(LINUX26_DIR)/.config
touch -c $@
linux26-menuconfig: $(LINUX26_DIR)/.patched host-sed
- [ -f $(LINUX26_DIR)/.config ] || cp $(LINUX26_KCONFIG) $(LINUX26_DIR)/.config
+ if [ ! -f $(LINUX26_DIR)/.config ]; then \
+ [ -n "$(LINUX26_KCONFIG)" ] && [ -f $(LINUX26_KCONFIG) ] && \
+ cp $(LINUX26_KCONFIG) $(LINUX26_DIR)/.config || \
+ true; \
+ fi
$(MAKE) $(LINUX26_MAKE_FLAGS) -C $(LINUX26_DIR) menuconfig
-[ -f $(LINUX26_DIR)/.config ] && touch $(LINUX26_DIR)/.configured