summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
authorRichard Braun <rbraun@sceen.net>2012-12-13 00:28:11 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-16 01:01:14 +0100
commita0df7e1f0bc9247069c0598405e519dd7e190ce3 (patch)
tree035cb88bf5a0ecb5f7c1c453a232bd2168ce6d1a /system
parent4fe78ce36cf2d53ee7b7e9b719e0d56937c58941 (diff)
downloadbuildroot-novena-a0df7e1f0bc9247069c0598405e519dd7e190ce3.tar.gz
buildroot-novena-a0df7e1f0bc9247069c0598405e519dd7e190ce3.zip
system: add option to configure TERM variable
This option is useful for cases where the terminal isn't a bare serial vt100, but e.g. a linux tty with more features. Signed-off-by: Richard Braun <rbraun@sceen.net> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'system')
-rw-r--r--system/Config.in6
-rw-r--r--system/system.mk5
2 files changed, 9 insertions, 2 deletions
diff --git a/system/Config.in b/system/Config.in
index 622b2427f..a557ea035 100644
--- a/system/Config.in
+++ b/system/Config.in
@@ -154,6 +154,12 @@ config BR2_TARGET_GENERIC_GETTY_BAUDRATE
default "57600" if BR2_TARGET_GENERIC_GETTY_BAUDRATE_57600
default "115200" if BR2_TARGET_GENERIC_GETTY_BAUDRATE_115200
+config BR2_TARGET_GENERIC_GETTY_TERM
+ string "Value to assign the TERM environment variable"
+ default "vt100"
+ help
+ Specify a TERM type.
+
config BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW
bool "remount root filesystem read-write during boot"
default y
diff --git a/system/system.mk b/system/system.mk
index 4185202b7..353d0ba1b 100644
--- a/system/system.mk
+++ b/system/system.mk
@@ -2,6 +2,7 @@ TARGET_GENERIC_HOSTNAME:=$(call qstrip,$(BR2_TARGET_GENERIC_HOSTNAME))
TARGET_GENERIC_ISSUE:=$(call qstrip,$(BR2_TARGET_GENERIC_ISSUE))
TARGET_GENERIC_GETTY:=$(call qstrip,$(BR2_TARGET_GENERIC_GETTY_PORT))
TARGET_GENERIC_GETTY_BAUDRATE:=$(call qstrip,$(BR2_TARGET_GENERIC_GETTY_BAUDRATE))
+TARGET_GENERIC_GETTY_TERM:=$(call qstrip,$(BR2_TARGET_GENERIC_GETTY_TERM))
target-generic-hostname:
mkdir -p $(TARGET_DIR)/etc
@@ -14,13 +15,13 @@ target-generic-issue:
echo "$(TARGET_GENERIC_ISSUE)" > $(TARGET_DIR)/etc/issue
target-generic-getty-busybox:
- $(SED) '/# GENERIC_SERIAL$$/s~^.*#~$(TARGET_GENERIC_GETTY)::respawn:/sbin/getty -L $(TARGET_GENERIC_GETTY) $(TARGET_GENERIC_GETTY_BAUDRATE) vt100 #~' \
+ $(SED) '/# GENERIC_SERIAL$$/s~^.*#~$(TARGET_GENERIC_GETTY)::respawn:/sbin/getty -L $(TARGET_GENERIC_GETTY) $(TARGET_GENERIC_GETTY_BAUDRATE) $(TARGET_GENERIC_GETTY_TERM) #~' \
$(TARGET_DIR)/etc/inittab
# In sysvinit inittab, the "id" must not be longer than 4 bytes, so we
# skip the "tty" part and keep only the remaining.
target-generic-getty-sysvinit:
- $(SED) '/# GENERIC_SERIAL$$/s~^.*#~$(shell echo $(TARGET_GENERIC_GETTY) | tail -c+4)::respawn:/sbin/getty -L $(TARGET_GENERIC_GETTY) $(TARGET_GENERIC_GETTY_BAUDRATE) vt100 #~' \
+ $(SED) '/# GENERIC_SERIAL$$/s~^.*#~$(shell echo $(TARGET_GENERIC_GETTY) | tail -c+4)::respawn:/sbin/getty -L $(TARGET_GENERIC_GETTY) $(TARGET_GENERIC_GETTY_BAUDRATE) $(TARGET_GENERIC_GETTY_TERM) #~' \
$(TARGET_DIR)/etc/inittab
# Find commented line, if any, and remove leading '#'s