summaryrefslogtreecommitdiffstats
path: root/support/kconfig/patches/15-fix-qconf-moc-rule.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-04-04 11:24:24 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-04-11 09:30:39 +0200
commit6997e461fdb39985957d24d81e612113cf39e35c (patch)
tree096947e214caf457ffdb005522698f3e747ad08a /support/kconfig/patches/15-fix-qconf-moc-rule.patch
parentcfe70c5e13fcf6d99394c646c758236a79041653 (diff)
downloadbuildroot-novena-6997e461fdb39985957d24d81e612113cf39e35c.tar.gz
buildroot-novena-6997e461fdb39985957d24d81e612113cf39e35c.zip
support/kconfig: upgrade to 3.9-rc2
Our kconfig code is updated to the version of kernel 3.9-rc2. No major issues during the migration, except: * Some conflicts when applying 03-change-config-option-prefix.patch due to upstream kernel changes. * The need of adding a new patch, 15-fix-qconf-moc-rule.patch, to fix the make rule that generates the moc file for the Qt-based interface. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Tested-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'support/kconfig/patches/15-fix-qconf-moc-rule.patch')
-rw-r--r--support/kconfig/patches/15-fix-qconf-moc-rule.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/support/kconfig/patches/15-fix-qconf-moc-rule.patch b/support/kconfig/patches/15-fix-qconf-moc-rule.patch
new file mode 100644
index 000000000..eae978ebf
--- /dev/null
+++ b/support/kconfig/patches/15-fix-qconf-moc-rule.patch
@@ -0,0 +1,24 @@
+Fix the rule that generates the .moc file
+
+The Linux kernel has a "cmd" make function, but we don't have it in
+Buildroot, so we need to adjust this rule.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -307,11 +307,8 @@
+
+ $(obj)/qconf.o: $(obj)/qconf.moc
+
+-quiet_cmd_moc = MOC $@
+- cmd_moc = $(KC_QT_MOC) -i $< -o $@
+-
+ $(obj)/%.moc: $(src)/%.h $(obj)/.tmp_qtcheck
+- $(call cmd,moc)
++ $(KC_QT_MOC) -i $< -o $@
+
+ # Extract gconf menu items for I18N support
+ $(obj)/gconf.glade.h: $(obj)/gconf.glade