summaryrefslogtreecommitdiffstats
path: root/project
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-09-26 14:04:08 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-09-26 14:04:08 +0000
commit94b3420da9c94c3044faead59f145a99a098c423 (patch)
treef588aeaef52ffd3ab64b6e7aedb2839acd80407c /project
parent0915c62d9839bdc38f996ca36c6b8e2f5329a0b4 (diff)
downloadbuildroot-novena-94b3420da9c94c3044faead59f145a99a098c423.tar.gz
buildroot-novena-94b3420da9c94c3044faead59f145a99a098c423.zip
project/Makefile.in: workaround issue with out-of-tree builds
Other packages might also support Linux-style out of tree builds with the O=<dir> syntax (E.G. Busybox does). As make automatically forwards command line variable definitions those packages get very confused. Fix this by telling make to not do so
Diffstat (limited to 'project')
-rw-r--r--project/Makefile.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/project/Makefile.in b/project/Makefile.in
index 6aa1d43e9..cc1043ba1 100644
--- a/project/Makefile.in
+++ b/project/Makefile.in
@@ -32,6 +32,12 @@ ifdef O
ifeq ("$(origin O)", "command line")
BASE_DIR := $(shell mkdir -p $(O) && cd $(O) && pwd)
$(if $(BASE_DIR),, $(error output directory "$(O)" does not exist))
+
+# other packages might also support Linux-style out of tree builds
+# with the O=<dir> syntax (E.G. Busybox does). As make automatically
+# forwards command line variable definitions those packages get very
+# confused. Fix this by telling make to not do so
+MAKEOVERRIDES =
endif
endif