summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-07-06 17:18:50 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-07-07 21:19:45 +0200
commit478f826518e1cf769abfb69da9361d931be15f8c (patch)
tree9ff29864ff2e765dac980e87567a8ae51b6b51de /package
parent8508dbb6d279800f0a5d6a1d320171db2a7d545c (diff)
downloadbuildroot-novena-478f826518e1cf769abfb69da9361d931be15f8c.tar.gz
buildroot-novena-478f826518e1cf769abfb69da9361d931be15f8c.zip
iptables: fix build after linux-headers changes
As reported by 'scanf' on IRC, the iptables now fails to build because of a missing <asm/cache.h> header in the kernel headers. The package directly uses $(LINUX_HEADERS_DIR), which is not correct: this is the source directory of the kernel, not where they are installed, and in addition, this directory is empty/does not exist when using external toolchains. Instead, we use $(STAGING_DIR)/usr, which contains the kernel headers, as part of the toolchain headers. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package')
-rw-r--r--package/iptables/iptables.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/iptables/iptables.mk b/package/iptables/iptables.mk
index cfb227ad9..f548cb9f4 100644
--- a/package/iptables/iptables.mk
+++ b/package/iptables/iptables.mk
@@ -12,7 +12,7 @@ IPTABLES_DEPENDENCIES = host-pkgconf
IPTABLES_LICENSE = GPLv2
IPTABLES_LICENSE_FILES = COPYING
-IPTABLES_CONF_OPT = --libexecdir=/usr/lib --with-kernel=$(LINUX_HEADERS_DIR)
+IPTABLES_CONF_OPT = --libexecdir=/usr/lib --with-kernel=$(STAGING_DIR)/usr
define IPTABLES_TARGET_SYMLINK_CREATE
ln -sf xtables-multi $(TARGET_DIR)/usr/sbin/iptables