summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-07-05 10:40:52 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-07-05 15:30:41 +0200
commit197006a41c1a0450bf6350d5742e186b5b0c69de (patch)
treee2bb0d3096eb9f611373fd6d2638d79ce7699ad1 /package
parent885449e4b9171283a8106957db5cf6139ef2273a (diff)
downloadbuildroot-novena-197006a41c1a0450bf6350d5742e186b5b0c69de.tar.gz
buildroot-novena-197006a41c1a0450bf6350d5742e186b5b0c69de.zip
gcc: apply PowerPC patch when needed
When converting gcc to the package infrastructure, a specific thing for PowerPC was forgotten: applying the conditional patch powerpc-link-with-math-lib.patch.conditional. This breaks the build of some PowerPC toolchains, with failures such as: <http://jenkins.free-electrons.com/job/buildroot/./config=qemu_ppc_virtex_ml507_defconfig/ws/output/host/usr/lib/gcc/powerpc-buildroot-linux-uclibc/4.7.3/../../../../powerpc-buildroot-linux-uclibc/lib/libgcc_s.so.1>: undefined reference to `copysignl' Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Tested-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package')
-rw-r--r--package/gcc/gcc.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/gcc/gcc.mk b/package/gcc/gcc.mk
index 790762da7..968354b41 100644
--- a/package/gcc/gcc.mk
+++ b/package/gcc/gcc.mk
@@ -38,8 +38,17 @@ endef
# Apply patches
#
+ifeq ($(ARCH)-$(BR2_GCC_SHARED_LIBGCC),powerpc-y)
+ifneq ($(BR2_SOFT_FLOAT),)
+define HOST_GCC_APPLY_POWERPC_PATCH
+ support/scripts/apply-patches.sh $(@D) package/gcc/$(GCC_VERSION) powerpc-link-with-math-lib.patch.conditional
+endef
+endif
+endif
+
define HOST_GCC_APPLY_PATCHES
support/scripts/apply-patches.sh $(@D) package/gcc/$(GCC_VERSION) \*.patch
+ $(HOST_GCC_APPLY_POWERPC_PATCH)
endef
#