summaryrefslogtreecommitdiffstats
path: root/package/python/python-2.7-103-optional-sqlite.patch
diff options
context:
space:
mode:
authorSamuel Martin <s.martin49@gmail.com>2012-11-30 11:46:27 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-30 14:31:07 -0800
commit4b3425c0bbe43a6c537a8d0833eec3826f623f67 (patch)
tree60aead06e15f706d4fe152e16238a0f8af340a68 /package/python/python-2.7-103-optional-sqlite.patch
parent7364f0cb2288262786e38401c91a47a01ba024cb (diff)
downloadbuildroot-novena-4b3425c0bbe43a6c537a8d0833eec3826f623f67.tar.gz
buildroot-novena-4b3425c0bbe43a6c537a8d0833eec3826f623f67.zip
python2: bump to 2.7.3
Pyhton 2.7.3 includes several security fixes. See: http://www.python.org/download/releases/2.7.3/ Also fixes the patch making sqlite optional and remove the symlink patch (which has been fixed upstream). Signed-off-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python/python-2.7-103-optional-sqlite.patch')
-rw-r--r--package/python/python-2.7-103-optional-sqlite.patch31
1 files changed, 30 insertions, 1 deletions
diff --git a/package/python/python-2.7-103-optional-sqlite.patch b/package/python/python-2.7-103-optional-sqlite.patch
index 4172bae48..a915c55c3 100644
--- a/package/python/python-2.7-103-optional-sqlite.patch
+++ b/package/python/python-2.7-103-optional-sqlite.patch
@@ -1,10 +1,12 @@
Add option to disable the sqlite3 module
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Signed-off-by: Samuel Martin <s.martin49@gmail.com>
---
+ Makefile.pre.in | 24 +++++++++++++++++-------
configure.in | 9 +++++++++
- 1 file changed, 9 insertions(+)
+ 2 file changed, 9 insertions(+)
Index: Python-2.7.2/configure.in
===================================================================
@@ -26,3 +28,30 @@ Index: Python-2.7.2/configure.in
AC_SUBST(PYDOC)
AC_ARG_ENABLE(pydoc,
+Index: Python-2.7.2/Makefile.pre.in
+===================================================================
+--- Python-2.7.2.orig/Makefile.pre.in
++++ Python-2.7.2/Makefile.pre.in
+@@ -875,7 +874,7 @@
+ lib-tk/test/test_ttk test test/data \
+ test/cjkencodings test/decimaltestdata test/xmltestdata test/subprocessdata \
+ test/tracedmodules email/test email/test/data \
+- json/tests sqlite3/test bsddb/test \
++ json/tests bsddb/test \
+ ctypes/test distutils/tests unittest/test
+ endif
+
+@@ -884,6 +882,13 @@
+ LIBSUBDIRS += pydoc_data
+ endif
+
++ifeq (@SQLITE3@,yes)
++LIBSUBDIRS += sqlite3
++ifeq (@TEST_MODULES@,yes)
++LIBSUBDIRS += sqlite3/test
++endif
++endif
++
+ libinstall: build_all $(srcdir)/Lib/$(PLATDIR) $(srcdir)/Modules/xxmodule.c
+ @for i in $(SCRIPTDIR) $(LIBDEST); \
+ do \