summaryrefslogtreecommitdiffstats
path: root/package/python/python-2.7-014-verbose-module-build.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-09-18 18:05:22 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-18 21:05:01 +0200
commita21642c7eb06eeffe621e7eaef1a85cb9b4589f8 (patch)
tree7ad88cac4838dc3968401f6657f7e6cf8f362630 /package/python/python-2.7-014-verbose-module-build.patch
parent16d6e9b3420e78a89960b8b68202ea46a618810d (diff)
downloadbuildroot-novena-a21642c7eb06eeffe621e7eaef1a85cb9b4589f8.tar.gz
buildroot-novena-a21642c7eb06eeffe621e7eaef1a85cb9b4589f8.zip
python: fix build by adding some more patches
The removal of -L flags from TARGET_LDFLAGS in 7e3e8ec040b06d6e2fb69e55c004f1ebc02c76d0 has trigerred some more issues with Python, requiring some more hacky fixes. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python/python-2.7-014-verbose-module-build.patch')
-rw-r--r--package/python/python-2.7-014-verbose-module-build.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/package/python/python-2.7-014-verbose-module-build.patch b/package/python/python-2.7-014-verbose-module-build.patch
new file mode 100644
index 000000000..a5be60f2a
--- /dev/null
+++ b/package/python/python-2.7-014-verbose-module-build.patch
@@ -0,0 +1,19 @@
+Enables verbose output when building modules
+
+Patch borrowed from OpenBricks.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: Python-2.7.1/Makefile.pre.in
+===================================================================
+--- Python-2.7.1.orig/Makefile.pre.in
++++ Python-2.7.1/Makefile.pre.in
+@@ -408,7 +408,7 @@
+ # Build the shared modules
+ sharedmods: $(BUILDPYTHON)
+ @case $$MAKEFLAGS in \
+- *s*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' CROSS_COMPILING=@CROSS_COMPILING@ DISABLED_EXTENSIONS="$(DISABLED_EXTENSIONS)" CONFIG_ARGS="$(CONFIG_ARGS)" $(PYTHON_FOR_BUILD) -E $(srcdir)/setup.py -q build;; \
++ *s*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' CROSS_COMPILING=@CROSS_COMPILING@ DISABLED_EXTENSIONS="$(DISABLED_EXTENSIONS)" CONFIG_ARGS="$(CONFIG_ARGS)" $(PYTHON_FOR_BUILD) -E $(srcdir)/setup.py build;; \
+ *) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' CROSS_COMPILING=@CROSS_COMPILING@ DISABLED_EXTENSIONS="$(DISABLED_EXTENSIONS)" CONFIG_ARGS="$(CONFIG_ARGS)" $(PYTHON_FOR_BUILD) -E $(srcdir)/setup.py build;; \
+ esac
+