summaryrefslogtreecommitdiffstats
path: root/package/pkg-generic.mk
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2012-12-06 13:16:00 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-06 17:13:57 -0800
commit054f97e1f2de337ea0c788d766212a36d6d4e41c (patch)
treeaacbce2fb3f3c084da5848f71541faee8ac26453 /package/pkg-generic.mk
parent9a6d3456f3e7965f30648fd09ef54b13109d210d (diff)
downloadbuildroot-novena-054f97e1f2de337ea0c788d766212a36d6d4e41c.tar.gz
buildroot-novena-054f97e1f2de337ea0c788d766212a36d6d4e41c.zip
pkg-infra: add <pkg>-extract and <pkg>-patch targets to OVERRIDE support
The legal-info target (and possibly others as well) depends on <pkg>-extract to make sure the license file is available. However, when <PKG>_OVERRIDE_SRCDIR is active, the <pkg>-extract target doesn't exist. To solve this, we add <pkg>-extract which depends on <pkg>-rsync. While we're at it, we do the same for <pkg>-patch. That avoids the same problem in the future if something starts depending on <pkg>-patch. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: Luca Ceresoli <luca@lucaceresoli.net> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/pkg-generic.mk')
-rw-r--r--package/pkg-generic.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index fc05dc66b..a570ad758 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -390,6 +390,9 @@ $(1)-configure: $(1)-depends \
$(1)-depends: $(1)-rsync $$($(2)_DEPENDENCIES)
+$(1)-patch: $(1)-rsync
+$(1)-extract: $(1)-rsync
+
$(1)-rsync: $$($(2)_TARGET_RSYNC)
$(1)-source: $$($(2)_TARGET_RSYNC_SOURCE)