summaryrefslogtreecommitdiffstats
path: root/package/libgtk2/libgtk2.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-01-06 11:29:29 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-12 22:44:51 +0100
commit0e55b8dc8ac082ab8adb48dc790a4105a7630304 (patch)
treed8f480c5edb7cc7c6a465940e826cd4a14dae720 /package/libgtk2/libgtk2.mk
parente28272314b3e014e780ac44b9015da24292966a4 (diff)
downloadbuildroot-novena-0e55b8dc8ac082ab8adb48dc790a4105a7630304.tar.gz
buildroot-novena-0e55b8dc8ac082ab8adb48dc790a4105a7630304.zip
libgtk2: replace dependency on X.org server by dependency on libraries
libgtk2 is a X client library, so it doesn't make sense for it to depend on the X.org server. Instead, it should depend on the X client libraries. This patch therefore replaces the dependency on the X server by a dependency on libX11, libXext, libXrender and fontconfig, that are the mandatory requirements to build the X backend of Gtk. [Peter: don't add an empty line before gtk demo help text] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libgtk2/libgtk2.mk')
-rw-r--r--package/libgtk2/libgtk2.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/libgtk2/libgtk2.mk b/package/libgtk2/libgtk2.mk
index 9adb6b9f4..3dcecbfe0 100644
--- a/package/libgtk2/libgtk2.mk
+++ b/package/libgtk2/libgtk2.mk
@@ -82,7 +82,8 @@ ifeq ($(BR2_PACKAGE_XORG7),y)
--x-includes=$(STAGING_DIR)/usr/include/X11 \
--x-libraries=$(STAGING_DIR)/usr/lib \
--with-gdktarget=x11
- LIBGTK2_DEPENDENCIES += xlib_libXcomposite xserver_xorg-server
+ LIBGTK2_DEPENDENCIES += xlib_libXcomposite fontconfig xlib_libX11 \
+ xlib_libXext xlib_libXrender
else
LIBGTK2_CONF_OPT += --without-x
endif